2012年07月26日

[Ruby][Mac] Macへのrspecのインストール

過去の自分の記事を見てrspecもインストールしてみました。

t2low:~ t2low$ gem install rspec
Fetching: rspec-core-2.11.1.gem (100%)
ERROR: While executing gem ... (Gem::FilePermissionError)
You don't have write permissions into the /Library/Ruby/Gems/1.8 directory.


あれ?パーミッションのエラーがでました。
こういうときはsudoでいいのかな?

t2low:~ t2low$ sudo gem install rspec
Password:
Fetching: rspec-core-2.11.1.gem (100%)
Fetching: diff-lcs-1.1.3.gem (100%)
Fetching: rspec-expectations-2.11.1.gem (100%)
Fetching: rspec-mocks-2.11.1.gem (100%)
Fetching: rspec-2.11.0.gem (100%)
Successfully installed rspec-core-2.11.1
Successfully installed diff-lcs-1.1.3
Successfully installed rspec-expectations-2.11.1
Successfully installed rspec-mocks-2.11.1
Successfully installed rspec-2.11.0
5 gems installed
Installing ri documentation for rspec-core-2.11.1...
Installing ri documentation for diff-lcs-1.1.3...
Installing ri documentation for rspec-expectations-2.11.1...
Installing ri documentation for rspec-mocks-2.11.1...
Installing ri documentation for rspec-2.11.0...
Installing RDoc documentation for rspec-core-2.11.1...
Installing RDoc documentation for diff-lcs-1.1.3...
Installing RDoc documentation for rspec-expectations-2.11.1...
Installing RDoc documentation for rspec-mocks-2.11.1...
Installing RDoc documentation for rspec-2.11.0...


インストールでけました。

t2low:~ t2low$ rspec -v
2.11.1


お約束のバージョン確認でおしまいです。
タグ:Mac ruby RSpec
posted by t2low at 03:51| Mac/iOS

2012年07月25日

[Mac][Ruby] RubyGemsのインストール

本当はMacアプリを開発してみたいのですが、忙しくて入門書を買いに行く時間がないので、その他のやってみたいことを少しずつ進めてみます。

とりあえずRubyGemsをインストールしました。
↓こちらのサイトを参考にさせていただきました(バージョン違うくらいでそのままできた)。

http://d.hatena.ne.jp/makimura_amane/20091209/p2

t2low:~ t2low$ sudo ruby Downloads/rubygems-1.8.24/setup.rb 
Password:
RubyGems 1.8.24 installed


前にもWindowsにインストールしたことを思い出しました。
ただ、そのWindowsはこわれてしまったのですよね…。昨日。

t2low:~ t2low$ gem -v
1.8.24
t2low:~ t2low$ gem update --system
Latest version currently installed. Aborting.


続きの確認をして、今日はおしまい。
タグ:Mac ruby rubygems
posted by t2low at 03:33| Mac/iOS

2012年07月22日

[Mac] MacBook Air買いました。と、Homebrewのインストール。

MacBook Airを買いました。
新しいやつです。13インチです。
Core i7、8GBにしました。快適です。

XcodeとかEclipseとかインストールしました。
とりあえず、Androidアプリは作れる状態です。
定番アプリを全然知らないのでオススメがあれば教えて欲しいです。

GitをインストールするのにMacPortsとHomebrewとどちらが良いのか悩んでいたら、知人にHomebrewの方が良いと教えられたので素直に従いました。
何かあったときに教えてもらえる人がいた方が良さそうですし。
とりあえずは↓のサイトを参考にさせてもらってインストールを進めました。

http://blog.withsin.net/2012/02/17/mac-homebrew/

簡単なんですね。
ターミナルで以下のコマンドをコピペするだけで基本的なインストールは完了したようです。

ruby -e "$(/usr/bin/curl -fsSL https://raw.github.com/mxcl/homebrew/master/Library/Contributions/install_homebrew.rb)"


サイトのとおりに進めました。
brew help

で、動作確認。動いてました。
brew update

と打つとHomebrewのアップデートができるようです。
これも正常に簡単に終わりました。すごいですね。

さて、つづいてGitのインストール。
brew install git

なんか勝手にダウンロードやらmakeやらをやってくれました。
33秒でインストール成功。はやーい。
最後に
git --version

で、gitの動作確認。正常に動きました。
すげーですね。こりゃすげーですわ。

そんなこんなで久しぶりにマカーになります。
どうぞよろしくおねがいします。
posted by t2low at 02:51| Mac/iOS

2012年07月19日

[Android] ADT r20でAndroidプロジェクトが作れない

おひさしぶりです。

EclipseのJunoが出てたのでインストールしてみました。
ADTもr20をインストールしました。
そしたらAndroidのプロジェクトを新しく作れなくなりました。

同じような症状の人がいないか検索してみました。
やっぱり同じ症状の人がいました。
やることは3つ。

(1) SDK Managerでインストールされているサポートライブラリをアンインストールする
(2) SDK Managerでサポートライブラリを再インストールする
(3) eclipseを再起動する

これで僕のPCでは新しくAndroidプロジェクトを作れるようになりました。

タグ:android Eclipse adt
posted by t2low at 09:27| Android